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Preface

� Preface� 1

Use of This Book
This workbook is an introductory tutorial to geometric modelings using SOLIDWORKS 2015.  It is not intended to 
be a comprehensive guide to parts and assembly modelings.  It is prepared mainly for those students who have no 
experience in SOLIDWORKS geometric modeling, but want to acquire some.  I provide this workbook to the 
students in my classroom and require them to complete the exercises in 3-4 weeks, to make them feel more 
comfortable when working on advanced capabilities of SOLIDWORKS, such as Simulation, Motion.

Companion Webpage
A webpage is maintained for this book:

http://myweb.ncku.edu.tw/~hhlee/Myweb_at_NCKU/SWG2015.html

The webpage contains links to following resources: (a) videos that demonstrate the steps of each section in this book, 
and (b) the finished SOLIDWORKS files of each section.  (c) This book, in PDF format.
� As for the finished files, if everything works smoothly, you may not need them at all.  Every model can be built from 
scratch by following the steps in the book.  I provide these files just in case you need them.  For example, when you run 
into trouble and you don't want to redo it from the beginning, you may find these files useful.  Or you may happen to 
have trouble following the steps in the book, you can then look up the details in these files.

Notations
Chapters and sections are numbered in a traditional way.  Each section is further divided into subsections.  For example, 
the first subsection of the second section of Chapter 3 is denoted as "3.2-1."  Textboxes in a subsection are ordered 
with numbers, each of which is enclosed by a pair of square brackets (e.g., [4]).  We refer to that textbox as "3.2-1[4]."  
When referring to a textbox from the same subsection, we drop the subsection identifier.  For example, we simply write 
"[4]."  Notations used in this book are summarized as follows (for further illustration, see page 4):

� 3.2-1� Numbers after a hyphen are subsection numbers.
� [1], [2], ...� Numbers with square brackets are textbox numbers.
� SOLIDWORKS� SOLIDWORKS terms are boldfaced.
� (Round-cornered textboxes)� A round-cornered textbox indicates some mouse or keyboard actions are needed.
� (Sharp-cornered textboxes)� A sharp-cornered textbox is used for commentary only; no mouse or keyboard
� � actions are needed in that step.
� #� A symbol # is used to indicate the last textbox of a subsection.

�
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webpage: myweb.ncku.edu.tw/~hhlee
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Arm

� Section 1.1  Arm� 3

Section 1.1

1.1-1  About the Arm

 X

 Y

1.375

2.
25

Unit: in.

Thickness: 0.125 in.

R0.5

3×D0.25

R0.25

2 ×R0.313

[3] Before creating a geometry 
model, we must have a global 
coordinate system in mind.  In 
this case, the origin is here and 
the XY-plane is coincident with 
the back surface of the part. #

[1] The arm is a part 
of a clamping 

assembly.  In this 
section, we'll create a 
geometric model for 

the arm.

[2] Details of the 
arm.



About the Textboxes
1.  Within each subsection (e.g., 1.1-2), textboxes are ordered with numbers, each of which is enclosed by a pair of 
square brackets (e.g., [1]).  When you read the contents of a subsection, please follow the order of the textboxes.
2.  The textbox numbers are also used as reference numbers.  Inside a subsection, we simply refer to a textbox by its 
number (e.g., [1]).  From other subsections, we refer to a textbox by its subsection identifier and the textbox number 
(e.g., 1.1-2[1]).
3.  A textbox is either round-cornered (e.g., [1, 3, 4, 6]) or sharp-cornered (e.g., [2, 5]).  A round-cornered textbox 
indicates that mouse or keyboard actions are needed in that step.  A sharp-cornered textbox is used for 
commentary only; i.e., mouse or keyboard actions are not needed in that step.
4.  A symbol # is used to indicate the last textbox of a subsection [6], so that you don't leave out any textboxes.

SOLIDWORKS Terms
In this book, terms used in SOLIDWORKS are boldfaced (e.g., Part in [5, 6]) to facilitates the readability.

� Section 1.1  Arm� 4

1.1-2  Create a New Part

[4] Select File>New...

[2] User Interface.

[5] Part is selected by default.

[6] Click OK to 
create a Part 
document. #

[1] Double-click to 
Launch 

SOLIDWORKS.

[3] If you don't see Pull-Down Menus, 
move the mouse over the SOLIDWORKS 
logo (at the upper-left corner) to reveal the 
Pull-Down Menus and click to pin it 

down (fix it).



1.1-3  Set Up Units
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[1] Select 
Tools>Options... 

which is near the 
bottom of the menu.

[2] Click Document 
Properties tab.[3] Select 

Units.

[4] Select IPS.

[7] The Options command is 
also available here.

[6] Click OK.

[5] Select .123 (three 
decimal places).

[8] The units also 
can be set up 
from here. #



1.1-4  Draw a Circle
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[2] The Front plane 
(XY-plane) is ready 

for sketching.

[3] Right-click 
anywhere in the 

Graphics Area to 
display a Context 
Menu, and select 

Sketch 
Entities>Circle 

command.

[6]  Right-click anywhere 
in the Graphics Area 

and select Smart 
Dimension.

[4] Click at the origin and drag outward 
to create a circle.  Press ESC to dismiss 
the Circle command.  Press ESC again 

(or click anywhere in the Graphics 
Area other than the circle) to de-
select the circle.  The circle is blue-

colored (see [5]).

[5] Color Codes of Sketch Entities
A sketch entity is blue-colored (either light-blue or dark-blue) when it is not yet well-defined [4].  A well-defined entity 
(i.e., fixed in the space) becomes black (e.g., [7], next page).  When over-defined, an entity becomes red.

[1] In the Features Tree 
(on the left side of the user 
interface), right-click Front 

and select Sketch.
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[8] Scrolling the 
Mouse Wheel allows 
you to zoom in/out the 

sketch.

[9] Dragging the mouse 
with Control-Middle-
Button allows you to 

pan the sketch.

[12] To change the 
font size of 

dimension texts, 
select Dimension 
in the Document 

Properties 
(1.1-3[1, 2], page 5).

[7] Click the circle and move lower-
rightward to create a diameter; type 
0.25 (in) for the diameter.  The circle 
now turns black (fixed).  Use mouse 

functions to zoom in/out [8] or pan the 
sketch [9]. Drag the dimension to a 

location like this.  Finally, press ESC to 
dismiss the Smart Dimension.

[11] The font size of the 
dimension text can be 

changed (see [12]).

[13] Click Font... and then 
select a font size.  In this 

book, I use a 12-point font.

[10] If you made a 
mistake, you always can 

Undo the mistake.

[14] Image Quality can be 
used to improve the 

smoothness of the model. #



SOLIDWORKS Commands
There are literally hundreds of SOLIDWORKS commands (tools).  All commands can be found in the Pull-Down 
Menus [15].  Nevertheless, the most intuitive way to issue a command is through a context-sensitive menu, or simply 
called Context Menu [1, 3, 6] (page 6).  To issue a command with a Context Menu, you right-click an object on 
either the Part Tree [16] or the Graphics Area [17].  The commands available in a Context Menu depend on 
the kind of object you're working on (that's why it is called a context-sensitive menu).  In step [1] (page 6), the object 
you were working on is the Front plane; in steps [3, 6] (page 6). the object you were working on is the Graphics 
Area.
� After you accumulate some experiences, you may find that a more convenient way to issue a command is simply 
clicking a command on a Toolbar (e.g., [10], last page).  In this book, we roughly follow these rules to issue a 
command:
� 1.� As novices, we issue a command through a Context Menu, because it is the most intuitive way.
� 2.� If a command is not available with a Context Menu, we select it from the Pull-Down Menus, because
� � it is the most comprehensive way (i.e., all commands can be found there).
� 3.� As we accumulate experiences, we begin to issue a command by clicking a button in a Toolbar, because
� � it is the most convenient way.
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[15] Pull-Down Menus.
[17] Graphics Area. #

[16]  In SOLIDWORKS, this is called the 
FeatureManager Design Tree.  In this 
book, we'll call it Features Tree or simply 
Part Tree.  As you create entities, they're 

added to this tree structure.



1.1-5  Draw Another Circle
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[3] Move the cursor around the X-
axis until an Inference Line [4] 
appears.  Click to define the center, 
move away, and click again to define 

an arbitrary diameter.

[1] If Sketch Toolbar is 
not active, click Sketch to 

bring it up.

[4] Inference 
Line.

[2] Select Circle from the 
Sketch Toolbar.

[5] Click Smart 
Dimension from the 

Sketch Toolbar.

[6] Click the two center points 
one after another and then move 
the mouse upward and click again 

to create this horizontal 
dimension; type 1.375 (in).

[7] In the Head-Up Toolbar [8], 
click Zoom to Fit to fit the 

sketch within Graphics Area. [8] Head-Up Toolbar is at the 
top of the Graphics Area.



[9] Press ESC to dismiss 
Smart Dimension.  

Select Add Relation from 
the Context Menu (you 

may need to expand the 
Context Menu).

[15] De-select the 
two circles (press 

ESC or click 
anywhere on the 

Graphics Area). 
Now, the two 

circles have the 
same radius.  The 

second circle is still 
blue-colored, 

meaning that it is 
not well-defined 

yet.  We now 
impose another 

relation.

[17] In the Graphics 
Area, click the two 

circles' centers. 
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[18] Click 
Horizontal to make 
the two points align 

horizontally.

[19] A Horizontal 
relation is added, in 

addition to the 
existing Distance 

relation.

[20] Click OK to 
dismiss the 

Property Box.

[11] In the Graphics 
Area, click the two 
circles one after the 

other.  Note that their 
names appear here.

[10] A Property Box 
appears in place of the 

Part Tree.

[12] Click Equal to 
make their sizes equal.

[13] A relation 
between the two 
entities is added.

[14] Click OK to 
dismiss the Property 
Box.  The Part Tree 

re-appears.[16] Select Add 
Relation from 
the Context 
Menu again.

[21] Press ESC to de-select 
the two points. Now, the 

second circle becomes black 
(fixed) too. #



[2] Add a Vertical 
relation between the  

centers of the first and 
the third circles. #

1.1-7  Complete the Sketch
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[1] Follow a similar procedure in 
1.1-5 to draw this circle.  All three 
circles have the same radius; the 

vertical distance between the 
centers is 2.25 (in); and it aligns with 

the first circle vertically [2].

1.1-6  Draw the Third Circle

[1] Use Circle command to draw 
three circles which are concentric 

with the first three circles 
respectively.



[2] (Remember to press ESC twice.) Use 
Add Relation command to make the 

radii of the two upper circles equal.  Note 
that we've moved the dimensions for a 

better arrangement.
[3] Select Sketch Entities>Line 

command from the Context Menu.  
Before right-clicking to pop-up the 

Context Menu, make sure no command 
is active (if so, press ESC to dismiss it) and 

no sketch entity is selected (if so, press ESC 
to de-select it).

[4] Click the upper 
quarter-point of this 

circle...

[5] And click the upper 
quarter-point of this circle.  

Double-click to end the line 
drawing [6].
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[6] The Line command can be used to 
draw multiple line segments.  To end a 
session of line-drawing without dismiss 
the Line command, simply double-click.
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[12]The sketch 
after trimming.

[7] Follow steps [4, 5] to add 
this line.

[8] And also draw these two tangent lines.  
Note that, to draw the tangent lines, you click 
a circle NEAR quarter-points (rather than AT 
quarter-points).  For these two tangent lines, 

the tangent points are not at quarter-points.  If 
you made any mistakes, you always can Undo 

the mistakes (1.1-4[10], page 7).

[9] Press ESC to dismiss the 
Line command.  Select 

Trim Entities from the 
Context Menu.

[11] Click these 
segments to trim 
them away [12].

[10] In the Property Box, 
select Trim to closest.



[13] Use Smart 
Dimension (1.1-5[5], 
page 9) to specify this 

radius (0.313 in).

[15] And specify 
this radius (0.5 in).

[14] The radius of this arc 
is automatically adjusted to 
agree with the relation [2] 

(page 12).

[16] All sketch 
entities are fixed 

(black-colored) now.

[18] Select this vertex.

[17] Press ESC to dismiss 
Smart Dimension.  
Select Sketch Fillet from 
the Context Menu.
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[19] Type 0.25 (in) for 
the Fillet Radius.

[20] Click OK to 
accept the properties.

[21] A dimension is 
automatically added.  
This completes the 

sketch.



1.1-8  Generate 3D Model

[22] The commands used in this 
subsection can also be found in the 

Sketch Toolbar.  [23-26]

[23] Line 
command.

[25] Sketch 
Fillet command.

[24] Trim Entities 
command.

[27] Click Exit Sketch. #

[1] Click to highlight Sketch1 (which is 
the name of the sketch just created), and 

from Pull-Down Menus, select 
Insert>Boss/Base>Extrude....
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[5] Click OK.

[4] Type 0.125 (in) 
for the extruding 

Depth.

[2] The Extruded Boss/Base 
command is also available in the 

Features Toolbar [3].

[3] Features Toolbar.

[26] Add Relation 
command.



1.1-9  Wrap Up

[1] Select File>Close from 
the Pull-Down Menus to 
close the part document.  Or, 

you may select Window menu 
and click here.

[6] The finished 
3D model.

[7] From Pull-Down Menus, select 
File>Save or, on the Toolbar, click Save 
button.  The Toolbar is on the top of the 

user interface.  Save this part document with 
the file name Arm.  The full name of the 

document is Arm.SLDPRT. #
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[2] Select File>Exit from Pull-
Down Menus to quit 
SOLIDWORKS. #



Ratchet Wheel
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Section 1.2

1.2-1  About the Ratchet Wheel

[1] A ratchet wheel rotates in a certain 
direction controlled by a ratchet stop [2].  
In this section, we'll create a 3D model for 

this ratchet wheel.

 Y

 X

Unit: in.

Thickness: 0.25 in.

D0.25

1.
00

  15�
  60 �

[3] Details of the 
ratchet wheel. #

[2] The ratchet stop is used to 
control the rotational direction of 

the ratchet wheel.  The ratchet stop 
will be created in the next section.

1.2-2  Start Up

[1] Launch SOLIDWORKS and create a new part (1.1-2[1, 4-6], page 4).  Set up IPS unit system with 2 
decimal places for the length unit (1.1-3, page 5).  Start a sketch on Front plane (1.1-4[1, 2], page 6). #
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1.2-3  Draw a Construction Circle

[1] Select Circle from 
the Sketch Toolbar.

[2] Draw a circle 
centered at the 

origin.

[3] Select Smart 
Dimension.

[4] Specify the 
diameter of the circle 

(1.00 in).

[5] Press ESC to dismiss 
Smart Dimension.  

Right-click the circle and 
select Construction 

Geometry to convert the 
circle into a construction 

circle.

[6] The circle become 
centerlined.  In 

SOLIDWORKS, 
Construction Geometry is 

represented by centerlines.

[7] Construction Geometry
Frequently used Construction Geometries include construction lines and construction circles.  A construction 
line can be finite length or infinite length.  A Construction Geometry is used for reference only, it is not a 
geometric entity. #
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1.2-4  Draw Construction Lines

[1] Right-click anywhere in the 
Graphics Area and select 

Sketch Entities>Centerline 
to create construction lines.

[2] Draw a vertical line from 
the origin to the upper quarter 

point of the circle.  Double-
click anywhere to end the 

drawing without dismiss the 
Centerline command.

[3] Draw another 
centerline from the 
origin to the edge of 

the circle.

[4] Select Smart 
Dimension.

[5] Click the two 
centerlines one after 

the other to create an 
angle dimension; type 

15 (degrees). #



1.2-5  Draw a Tooth

[2] Draw lines starting 
here...
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[3] Then click here... [4] Finally  click here.  
Double-click to end the line-

drawing.

[1] Select Line.[5] Select Smart 
Dimension.

[6] Click the two newly 
created lines and specify 
an angle of 60 degrees. #



1.2-6  Duplicate the Tooth

[4] Click OK.
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[1] From Pull-Down Menus, select 
Tools>Sketch Tools>Circular 

Pattern.  And select the centerlined 
circle (to define the pattern direction).

[2] Type 24 for Number of 
Instances.

[3] Right-click this box and select 
Clear Selections from the 

Context Menu and then select the 
two line segments created in 1.2-5 

(last page) for Entities to 
Pattern. 

[5] The Circular Sketch 
Pattern command is also available 

by clicking the arrow next to 
Linear Sketch Pattern. #



1.2-7  Finished the Sketch and Generate 3D Model

[1] Select Circle.[3] Select Smart 
Dimension.

[2] Draw a circle 
centered at the 

origin.

� Section 1.2  Ratchet Wheel� 22

[4] Specify a 
diameter of 

0.25 in.

[5] Click Extruded Boss/Base 
(1.1-8[2], page 15).

[10] Save the part with the 
name Ratchet.  Close the 

file and exit 
SOLIDWORKS. #

[6] Type 0.25 (in).

[7] Click the region 
(see [8]).

[8] Click here to 
define the region.

[9] Click OK.



Ratchet Stop
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Section 1.3

1.3-1  About the Ratchet Stop

[2] The ratchet 
wheel has been 

created in the last 
section.

 Y

 X

0.57

0.
12
5

Unit: in.

Thickness: 0.125 in.

R0.56

R0.188

R0.34

0.1
6   S

lop
e: 

40
�

[3] Details of 
the ratchet 

stop. #

[1] The ratchet stop is used to 
control the rotational direction of 

the ratchet wheel [2].  In this 
section, we'll create a 3D solid 

model for the ratchet stop
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1.3-2  Start Up

[1] Launch SOLIDWORKS and create a new part (1.1-2, page 4).  Set up IPS unit system with 3 
decimal places for the length unit (1.1-3, page 5).  Create a sketch on Front plane (1.1-4[1, 2], page 6). #

1.3-3  Draw the Sketch

[1] Right-click the Graphics Area and select 
Sketch Entities>Centerpoint Arc.

[3] Select Smart 
Dimension.

[5] Press ESC to dismiss Smart Dimension.  
Select Sketch Entities>Tangent Arc from 

the Context Menu.

[2] Create an arc like this. 
Click the origin first, then 
starting point, and finally 

the ending point.

[4] Specify a radius of 
0.188 in.
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[6] Click this end point 
of the existing arc...

[7] Then define another end 
point.  Double-click to end the 

drawing without dismiss 
Tangent Arc command.

[8] Click another end 
point of the first arc...

[9] Then define another end.  
Press ESC to dismiss the 

Tangent Arc.

[10] From the Head-Up 
Toolbar, select Hide/
Show Items>View 
Sketch Relations to 

show relations. [11] A Tangent 
symbol appears next to 

each tangent point.

[12] Select View Sketch 
Relations again to hide 

the relations.
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[13] Select Line 
command.

[15] Click the small triangle 
next to Line command and 

select Centerline.

[14] Draw this line.

[16] In the Property Box, 
select Infinite length.

[17] Click the origin and 
then click any horizontal 

point to create a 
construction line of 

infinite length.
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[18] Select Smart 
Dimension.

[19] Finish up the sketch by 
specify the rest of the 

dimensions.  All entities 
must be black-colored. #

1.3-4  Generate 3D Model

[1] Extrude the sketch 
(1.1-8[2], page 15) 0.125 
inches to create this 3D 

model.

[2] Save the part with the 
name Stop.  Close the file and 

exit SOLIDWORKS. #



Cover Plate
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Section 1.4

1.4-1  About the Cover Plate

 X

 Y

Unit: in.

Thickness: 0.046 in.

8 ×R0.15

2.
00

0.376

1.
25

0.
75

0.
25

0.
25

0.562

1.50

6 ×R0.06

0.312 0.312

2 ×R0.188 2 ×D0.201

1.4-2  Start Up

[1] Launch SOLIDWORKS and create a new part (1.1-2, page 4).  Set up IPS unit system with 3 decimal 
places for the length unit (1.1-3, page 5).  Create a sketch on Front plane (1.1-4[1, 2], page 6). #

[1] In this exercise, 
we'll create a 3D 

solid model for this 
cover plate. #

 X



1.4-3  Draw the Sketch
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[1] Draw two 
circles; add an 
Equal relation 
for them; specify 

dimensions (0.201, 
2.0, 0.376).

[2] Draw two 
concentric circles; 

add an Equal 
relation for them.

[3] Specify a diameter 
of 0.376 in.

[4] While Dimension is 
still active, select 
Leaders tab.

[5] Click Radius.

[6] The dimension 
changes from 

diameter to radius 
(0.188 in).
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[7] Select Sketch Entities>Corner 
Rectangle from the Context Menu. [8] The Corner 

Rectangle is also available 
in the Sketch Toolbar.

[9] Draw a rectangle and 
specify dimensions (1.5, 

0.25, 0.25, 0.562).
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[10] Use Line command 
to draw these 5 line 

segments; specify 
dimensions (0.75, 1.25, 

0.312, 0.312).

[11] Use Trim Entities 
command to trim away 

these three line segments.

[12] After trimming.
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[13] Use Sketch Fillet 
(1.1-7[25], page 15) 

command to create these 6 
fillets of radius 0.06 in.

[14] Use Sketch 
Fillet command again 
to create these 4 fillets 

of radius 0.15 in.
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[15] Select Sketch Entities>3 Point Arc 
from the Context Menu and draw an arc 

like this.  Add two Tangent relations.

[17] Repeat step [15] three 
more times.

[16] The 3 Point Arc 
command is also available in 

the Sketch Toolbar.
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[18] Add Equal relation 
among these four arcs.  

Specify a radius dimension of 
0.15 inches.

[19] Trim away these 
four segments.
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[20] The finished 
sketch. #

1.4-4  Generate 3D Model

[1] Extrude the sketch 
0.046 inches to create 

this 3D model.

[2] Save the part with the file 
name Cover.  Close the file 
and exit SOLIDWORKS. #



Part Modeling
Chapter 2
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[1] In this exercise, we'll create a 3D solid model for a crank [2].  The model can be viewed as a series of three two-
step operations; each involves drawing a sketch on a plane and then extruding the sketch.  The material of the body is 
either added to or cut from the existing body.

Crank
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Section 2.1

2.1-1  About the Crank

 Y

 X

Unit: mm.

 7
5

 65

 Y

 Z

 20

 8

 R22

 D30

 D20

 R10

 2 ×R10
 2 ×D10[2] Details of 

the crank. #



2.1-2  Start Up
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[1] Launch SOLIDWORKS and create a new part.

[2] In the Options, 
select MMGS as unit 

system.

[3] Select None for Decimals 
(i.e., zero decimal places for the 

length unit).  Click OK. #

2.1-3  Draw a Sketch for the Base Body

[1] Create a 
sketch on 

Front plane.

[2] Draw 5 circles and four 
tangent lines.  Add an Equal 
relation for the two smallest 

circles;  add an Equal 
relation for the two medium 
circles.  Specify dimensions.
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[4] Add Horizontal 
relation between this point 
and the origin.  All entities 

turn black (fixed) now.

[3] Add Vertical 
relation between this 
point and the origin.

[5] Use Sketch Fillet 
command and select these 

two lines to create a fillet of 
radius of 10 mm.  Click Yes 

for a warning message.

[6] Trim away these 
three segments.

[7] Finished sketch. #



2.1-4  Extrude the Sketch to Create the Base Body  
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[1] Extrude the sketch 
8 mm to create this 

3D body. #

2.1-5  Add Features to the Base Body 

[2] From the Head-Up 
Toolbar, select View 

Orientation>Normal To.

[1] Right-click the frontal face of 
the base body and select Sketch 

from the Context Menu.

[3] The model rotates 
so that it is normal to 

your line of view.



[4] Draw a circle on 
the plane like this and 
specify a diameter of 

30 mm.
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[5] Extrude the 
sketch 12 mm.

[6] From the Head-Up 
Toolbar, select View 

Orientation>Isometric.

[8] Right-click this face 
and select Sketch from 
the Context Menu 

(see [1], last page)

[9] Click Normal To [10] 
and Draw a circle on the 

plane and specify a diameter 
of 20 mm.

[7] The Isometric 
is also available in 
the Standard 

Views Toolbar.

[10] The Normal To is also 
available in the Standard 

Views Toolbar.
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[11] From the Pull-Down Menus, select 
Insert>Cut>Extrude... or, from Features 

Toolbar, select Extruded Cut.

[12] Select Through All 
for End Condition.

[13] Click OK.

[14] The finished 
3D model.

[15] The Part Tree 
(Features Tree).

[17] The base body.

[18] The boss.

[16] The reference 
geometries.

[19] The hole.

[20] A part consists of reference geometries, base body, 
and features on the base body.  In this example, the 
features added to the base body are the boss and the 
hole.  Note that it is equally good to treat the two small 
holes as features on the base body.

[21] Save the part with the file name Crank.  
Exit SOLIDWORKS. #



[1] In this exercise, we'll create a 3D solid model for a Geneva gear index [2].

Geneva Gear Index
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Section 2.2

2.2-1  About the Geneva Gear Index

 Y
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[2] Details of the 
Geneva gear index. #



[1] Launch SOLIDWORKS and create a new part.  Set up IPS unit system with 3 decimal 
places for the length unit. #
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2.2-2  Start Up

2.2-3  Draw a Sketch for 1/5 of the Gear Index

[1] Create a sketch on Front plane.

[2] Use Centerpoint 
Arc command to draw 
an arc centered at the 

origin and of a radius of 
1.235 in like this.

[3] Draw two lines, 
each connects the 
origin to an end 
point of the arc.

[4] Specify an angle 
dimension of   72�  for 

the sector.

[6] Draw two circles  
centered at the end 

points of the centerlined 
arc and of the same 

radius of 0.1 in.

[5] Use Centerpoint Arc 
command to draw another arc 

centered at the origin and of a radius 
of 0.625 in.  Convert the arc to a 

Construction Geometry 
(1.2-3[5], page 18).
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[8] Draw a line connecting 
the upper circle to the outer 
arc.  Add a Parallel relation 
between the line and the line 
next to it.  Add a Tangent 

relation between the line and 
the connecting circle.

[7] Draw a line connecting the 
lower circle to the outer arc.  

Add a Horizontal relation on 
the line and add a Tangent 

relation between the line and the 
connecting circle.

[9] Use Centerline command to 
draw a centerline starting from the 
origin.  Specify the length (1.529 in).  

Make the sector symmetric about the 
centerline.  To do this, select Add 

Relation, click the centerline and the 
two edge lines of the sector, and select 
Symmetric in the Property Box.



[10] Use Centerpoint 
Arc command to draw an 
arc centered at one end of 
the centerline.  Specify a 

radius of 0.63 in.
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[11] Trim away unwanted 
segments.  Some entities 
turn back to blue color; 
add relations to fix them 

(see [12-14]).

[12] Some entities turn back 
to blue, try to fix them by 

adding a Coincident 
relation for this point...

[13] And this line.  Add 
another Coincident for 

the other side of the sector.

[14] If steps [12, 13] don't fix all 
the entities.  Try to drag an unfixed 
entity to figure out what relations 

should be added. #



2.2-4  Extrude the Sketch   

[1] Extrude the sketch 
0.25 in.  This is a 1/5 of 

the gear index. #

2.2-5  Complete the Full Model
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[1] Highlight the newly created body in 
the Part Tree and, from Pull-Down 

Menus, select Insert>Pattern/
Mirror>Circular Pattern.

[2] The Circular Pattern 
command is also available in 
the Features Toolbar.

[4] Select the edge shown in 
[5] for Pattern Axis.

[5] This edge is used 
as Pattern Axis.

[3] The body is pre-selected 
for Features to Pattern.

[6] Click OK.
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[9] Select Hole for 
Hole Type and set 
up other settings as 

shown.

[10] Select 
Positions tab.

[11] Select the 
center of the face.

[12] Click OK.

[7] Right-click this face and select 
Sketch from the Context Menu.  
Draw a circle centered at the origin 
with a diameter of 0.5 in.  Extrude 

the sketch 0.19 in.

[8] Click to highlight this face 
and, from Pull-Down 

Menus, select 
Insert>Features>Hole>

Wizard...

.



[13] The finished 
3D model.

[14] The Hole Wizard 
command is also available in 

Features Toolbar.

[15] Save the part with the file name Geneva.  Close 
the file and exit SOLIDWORKS. #
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2.3-1  About the Yoke

Yoke
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Section 2.3

[1] The yoke is a part 
of a universal joint.  In 

this exercise, we'll 
create a 3D solid 

model for the yoke.

 Z
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[2] Details of the 
yoke. #



[1] Launch SOLIDWORKS and create a new part.  Set up IPS unit system with 3 decimal places for the length 
unit. #

2.3-2  Start Up

� Section 2.3  Yoke� 51

2.3-3  Create a Base Body

[1] Create a sketch on Front plane.

[2] Draw a sketch like this.  If 
there are any blue entities (not 

well-defined), see [3, 4].

[3] If there are any blue entities, select 
Hide/Show Items>View 

Sketch Relations (1.3-3[10], page 
25) to view all relations.  Add relations 

to fix the entities.

[4] Another way is to drag an 
unfixed entity to figure out 

what relations should be added.
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[5] Extrude the 
sketch 2 in.

[6] Select Mid Plane so that 
the sketch extrudes both sides 
(2 inches is the total depth). #

2.3-4  Create Rounds and Holes

[1] From Pull-Down Menus, select 
Insert>Features>Fillet/Round... 

Select Full Round Fillet and set up the 
properties like this (also see [2-5]).

[2] Face<1>.

[3] Face<2>.

[4] Face<3>.

[5] This is a Full 
Round Fillet.



[6] The Fillet command is also 
available on the Features 

Toolbar.  Click it.
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[7] Create another Full 
Round Fillet [1].

[9] Click Hole 
Wizard.

[8] Click this face.

[10] Set up the 
properties like this.

[11] Select Positions tab and click 
the arc-center of the selected face 
[8].  To locate the arc-center, move 

your mouse over the arc, the center 
will show up.

[12] Click OK. #

.



2.3-5  Create a Plane

[2] Type 3.55 (in) for 
Offset distance.

[3] Click OK.
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[1] Click to highlight Top 
and, from Pull-Down 

Menus, select 
Insert>Reference 

Geometry>Plane...

[4] A new plane is created by 
offsetting Top plane 3.55 in 

upward.

2.3-6  Create the Shaft

[1] Right-click the newly 
created plane and select 

Sketch from the 
Context Menu.

[2] Click Normal To 
(2.1-5[8], page 41) and draw a 
circle centered at the origin 

and with a diameter of 1.2 in.

[5] The Reference 
Geometry tools are also 
available on the Features 

Toolbar. #



[8] The finished 3D 
model.

[3] From the Features Toolbar, 
select Extruded Boss/Base and 

select Up To Surface for End 
Condition.
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[4] Select the top face 
of the existing body 

(see [5]).

[5] Face<1>.

[6] Click OK.

[9] Save the part with the file name Yoke.  Close the 
file and exit SOLIDWORKS. #

[7] Turn off View 
Planes.



2.4-1  About the Support

Support
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Section 2.4
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[1] The support is a 
part of the clamping 
assembly mentioned 

in Section 1.1.  In 
this exercise, we'll 
create a 3D solid 

model for the 
support.

[2] Details of the 
support. #



[1] Launch SOLIDWORKS and create a new part.  Set up IPS unit system and with 3 decimal places for the 
length unit. #
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2.4-2  Start Up

2.4-3  Create Vertical Plate

[1] Create a sketch on Front plane.

[2] Draw a sketch like this.  
Make sure all entities are 
fixed (black-colored).  If 

not, see [3].

[3] If there are any blue-colored 
entities, add missing Relations.  
Remember, one way to detect 

missing Relations is to drag an 
unfixed (blue-colored) entity.
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[4] Draw two circles 
like this.  Make sure all 

entities are fixed.

[5] Trim away 
unwanted segments.

[6] Use Sketch Fillet 
command to draw two 

fillets of the same radius of 
0.1 inches.  The two fillets 

may need to create 
separately.



[7] Extrude the sketch 
0.125 inches. #

2.4-4  Create Horizontal Plate
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[2] Select Reference 
Geometry>Plane from the 

Features Toolbar.

[1] Highlight Top.

[3] Type 0.875 (in) for 
Offset distance.

[4] Click Flip.
[5] The new plane.

[6] Click OK.



[12] Turn off View 
Planes. #

[9] Click Normal To 
and draw a sketch 

(including three circles of 
the same diameter) like 

this.  Make sure all 
entities are fixed.

� Section 2.4  Support� 60

[8] Click Sketch in the 
Sketch Toolbar.

[7] Make sure the 
new plane is 
highlighted.

[11] Extrude 
(upward) 0.125 

inches.

[10] Remember, one way to detect 
missing Relations is to drag an 

unfixed entity.  You may need to add 
a Coincident relation here.
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[7] Save the part with the file name Support.  
Close the file and exit SOLIDWORKS. #

2.4-5  Create Fillet

[1] In the 
Features 

Toolbar, click 
Fillet.

[2] Select 
Constant size.

[4] Edge<1>.

[6] Click OK.

[3] Select the edge 
shown in [4].

[5] Type 0.1 (in).



[1] So far, we exclusively used Extrude command to create 3D solids.  In this section, we introduce another 
command to create 3D solids: Revolve, which takes a sketch as the profile and revolves about an axis to create a 3D 
solid body.  We'll create a 3D solid model for a wheel [2].  The wheel is axisymmetric.  An axisymmetric body always 
can be created by drawing a profile then revolving about its axis of revolution.

Wheel
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Section 2.5
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2.5-1  About the Wheel

[2] Details of the 
wheel. #



[1] Launch SOLIDWORKS and create a new part.  Set up IPS unit system with 2 decimal places for the length 
unit. #
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2.5-2  Start Up

2.5-3  Create a Sketch for the Profile

[1] Create a sketch on Front plane.

[2] Draw a horizontal 
centerline of infinite 

length (see [3]) passing 
through the origin.  This 
centerline will be used 

as the axis of revolution.

[3] Click Infinite 
length in the 
properties box.

[4] Draw a vertical 
centerline of infinite 

length passing through 
the origin.  This 

centerline will be used 
as the axis of symmetry.

[5] Draw a sketch like 
this.  Make sure all 
entities are fixed.



[9] The finished sketch.
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[6] Select Tools>Sketch 
Tools>Mirror from Pull-Down 

Menus and select all entities (you may 
use Box-Select or Control-A) for 

Entities to mirror.

[7] Select the vertical 
centerline for Mirror 

about.

[8] Click OK.

[10] The Mirror command is 
also available in the Sketch 

Toolbar. #



2.5-4  Revolve the Sketch
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[1] While the sketch is 
highlighted, select 
Insert>Boss/

Base>Revolve...

[3] Select the horizontal 
centerline.

[4] Click OK.
[5] The finished 3D 

model.

[6] Save the part with the file name Wheel.  Close 
the file and exit SOLIDWORKS. #

[2] The Revolve command 
is also available in the 
Features Toolbar.



[1] In this section, we introduce another command to create 3D solids: Sweep, which takes a sketch as the path 
and another sketch as the profile; the profile then "sweeps" along the path to create a 3D solid body.  In this 
exercise, we'll create a 3D solid model for a transition pipe, which is used to connect two pipe segments. 

Transition Pipe
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Section 2.6
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2.6-1  About the Transition Pipe

[2] Details of the 
transition pipe. #



[1] Launch SOLIDWORKS and create a new part.  Set up IPS unit system with 2 decimal places for the length 
unit. #
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2.6-2  Start Up

2.6-3  Create a Sketch for the Path

2.6-4  Create a Sketch for the Profile

[1] Create a sketch on Front plane.

[2] Draw a sketch like this.  This 
sketch will be used as a sweeping 
path.  Note that, each end point 

aligns with the origin either vertically 
or horizontally.

[3] Click Exit Sketch in 
the Sketch Toolbar. #

[1] Right-click Top plane 
and select Sketch to create 

a second sketch.

[2] In the Standard Views 
Toolbar, click Normal To.

[3] Draw two concentric circles like this.  
This sketch will be used as a sweeping 

profile.  Note that the dimension 3.00 
(in) can be replaced by a Pierce relation 
between the center of the circles and the 

path created in 2.6-3[2].
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2.6-5  Create the Curved Pipe

[4] Click Exit Sketch in the 
Sketch Toolbar. #

[1] While the Profile 
sketch is highlighted, 

select Insert>Boss/
Base>Sweep...

[2] The Sweep command 
is also available in the 
Features Toolbar.

[3]The profile 
sketch (Sketch2) 

is pre-selected.

[4] Click to activate 
Path box.

[5] In the Graphics Area, click "+" 
sign to expand the Part Tree; the 

"+" sign becomes "-" sign.

[6] Select the Path sketch 
(Sketch1).

[7] Click 
OK.

[8]The curved pipe.  Note 
that the curved pipe also can 
be created by Revolving 

the Profile 90 degrees with 
an axis coincident with the 

Z-axis. #



2.6-6  Create the Lower End Plate
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[1] Right-click the bottom 
face of the curved pipe.

[2] And select Sketch to 
create a sketch (for the 

lower end plate).

[3] In the Standard 
Views Toolbar, click 

Normal To.

[4] Draw a sketch like this.  The 
sketch consists of 7 circles, 

including a construction circle of 
diameter 2.5 in and four circles of 

diameter 0.25 in.
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[5] In the Features 
Toolbar, click 

Extruded Boss/Base.

2.6-7  Create a Mirroring Plane

[6] Type 0.25 (in) for 
Depth.

[7] Click Reverse 
Direction.

[8] Click OK.

[9] The lower end 
plate. #

[1] Next, we want to create the upper end plate by using 
Mirror command.  The mirroring plane will be created 
by rotating the Top plane 45 degrees about an axis 
coincident with the Z-axis.  First, we create the axis.

[2] From Features Toolbar, 
select Reference 

Geometry>Axis.



[7] The created 
axis.

[3] From Features 
Tree, select Top 
and Right planes.

� Section 2.6  Transition Pipe� 71

[5] Two Planes is 
automatically selected.  An axis 
is created by intersecting the 

two selected planes.

[4] The Top and Right 
planes appear here.

[6] Click OK.

[8] From the Features 
Toolbar, select Reference 

Geometry>Plane.

[13] Click 
OK.

[9] From the Part 
Tree, select the newly 
created axis for First 

Reference.

[10] From the Part Tree, 
select Top plane for 

Second Reference.

[11] Click At 
Angle.

[12] Type 45 (deg) 
for Angle.
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[14] The mirroring 
plane. #

2.6-8  Create the Upper End Plate

[2] In Features Toolbar, 
click Mirror.

[1] Make sure the newly 
created plane is highlighted.

[3] From the Part Tree (or 
from the Graphics Area) 
select the lower end plate 

(Boss-Extrude1).

[4] Click OK.



[5] From Head-Up Toolbar, 
select Hide/Show 

Items>View Planes to turn 
off the planes display.

[6] The upper end plate. #

2.6-9  Create Fillets and Rounds
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[1, 6] From Features 
Toolbar, click Fillet.

[3] Edge <1>.

[4] Edge <2>.

[5] Click OK.

[2] Type 0.125 (in) for 
Radius and select the two 

edges shown in [3, 4].



[10] Click 
OK.

[7] Type 0.0625 (in) for 
Radius and select the 

two edges shown in [8, 9].
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[8] Edge <1>.

[9] Edge <2>.

[12] From Head-Up 
Toolbar, select Display 

Style>Shaded to remove 
the edge display.

[11] The finished 
model.

[13] Shaded model 
without edge display.

[14] Save the part with the file name Pipe.  
Close the file and exit SOLIDWORKS. #



Threaded Shaft
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Section 2.7

[2] The threaded shaft 
is a part of a clamping 

assembly. 

2.7-1  About the Threaded Shaft

[5] Thread form: 
Unified National 

Coarse.

[3] Major 
diameter
d = .375 in.

[4] Pitch
p = 1/16 in.
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[1] The threaded shaft is a part of the clamping mechanism 
mentioned in Sections 1.1 and 2.4 [2].  In this exercise, we 
will create a 3D solid model for the threaded shaft.

[6] Details of the 
threads. #
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2.7-3  Create a Shaft Base

[1] Launch SOLIDWORKS and create a new part.  Set up IPS unit system with 3 decimal places for the length 
unit. #

2.7-2  Start Up

[1] On Front 
plane, draw a 

sketch like this.

[2] Revolve (2.5-4[2], page 65) 
the sketch 360 degrees to create 
the shaft base.  Use the bottom 

line of the sketch as the Axis of 
Revolution [3].

[3] Use this line as the Axis of 
Revolution.

[4] The shaft base. #
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2.7-4  Create Threads

[1] On the Front plane, draw a single line 
of length 3.75 inches like this.  Remember 
to click Exit Sketch.  This sketch will be 

used as the sweeping Path.

[5] From the Part Tree, select the 
Sketch2 (created in [1]) for Path and 
set up other parameters like this.  Note 

that the number of turns (60) is calculated 
by 3.75/0.0625, where 0.0625 (in) is the 

thread pitch.  Click OK.

[2] On the Front plane, 
draw a sketch of trapezoid 

like this.  Remember to 
click Exit Sketch.  This 
sketch will be used as the 

sweeping Profile.

[3] With Sketch3 (created 
in[2]) highlighted, from 

Features Toolbar, click 
Swept Cut.

[4] Sketch3 is used 
as Profile.
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[7] Select this 
face...

[8] And click 
Sketch.[6] The threads.

[9] In the Sketch Toolbar, click 
Convert Entities.  This command 

converts the selected entities (here, the 
boundaries) into line entities.  This 

completes the sketch.

[10] Click Exit 
Sketch.

[11] In the Features 
Toolbar, click 

Extruded Cut.

[12] Select 
Through All.

[13] Click OK. #



2.7-5  Create a Hole
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[1] On the Front plane, draw a circle like 
this.  Remember to click Exit Sketch.

[2] With the sketch 
highlighted, from the 
Features Toolbar, 

select Extruded Cut 
and set up the 

parameters like this.

[3] The finished 
model.

[4] Save the part with the file name Shaft.  
Close the file and exit SOLIDWORKS. #



2.8-1  About the Lifting Fork

Lifting Fork
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Section 2.8

[1] The lifting fork is used in an LCD (liquid crystal display) manufacturing factory to handle glass panels.  In this 
section, we will create a 3D solid model for the lifting fork.
� The cross sections of the prongs (fingers) are not uniform along the length [2, 3, 4].  The Extrude command or 
Sweep command can not be used to created the prongs.  This exercise introduces a new command to create 3D 
solids: Loft, which takes a series of profiles and creates a 3D solid that fits through these profiles.
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[4] At the midway, 
the cross section is 

130x20 (mm). #

[3] At the tip, the 
cross section is 
100x10 (mm).

[2] At the root, the 
cross section is 
160x60 (mm).



2.8-3  Create a Transversal Beam
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[1] Launch SOLIDWORKS and create a new part.  Set up MMGS unit system with zero decimal places for 
the length unit. #

2.8-2  Start Up

[2] Extrude the 
sketch 200 mm to 

create the transversal 
beam.

[1] On Front plane, 
draw a sketch like this.

[3] The transversal 
beam. #
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2.8-4  Create Two Planes

[2] And, from Features 
Toolbar, select 

Reference 
Geometry>Plane.

[6] Two planes [7, 8] 
are created.

[1] Click this 
face...

[7] Plane1.

[8] Plane2. #

[5] Click OK.

[4] Type 2 for Number of 
planes to create.

[3] Type 1200 (mm).
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[1] Right-click this face 
and select Sketch.

[3] Right-click Plane1 
and select Sketch.

[5] Right-click Plane2 
and select Sketch.

2.8-5  Sketch Three Profiles

[2] Create a rectangle of 160 mm x 60 mm 
like this.  Click Exit Sketch.

[4] Create a rectangle of 130 mm x 20 mm 
like this.  Click Exit Sketch.

[6] Create a rectangle of 100 mm x 10 mm 
like this.  Click Exit Sketch. #



2.8-6  Create a Finger

[1] In the Part Tree, 
highlight the finger.
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2.8-7  Create the Other Fingers

[2] From the Features Toolbar, 
click Linear Pattern.

[1] From Features Toolbar, 
select Lofted Boss/Base.

[2] From Part Tree, select the 
three sketches (in the order 

shown) as Profiles.  The order is 
important.

[3] Click OK.

[4] The created 
finger. #
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[4] Edge<1>.

[3] Select an edge for Pattern 
Direction (see [4], click 

Reverse Direction if the 
direction is not rightward) and set 

up other parameters like this.

[5] Make sure 
Geometry 

pattern is de-
selected.

[6] Click OK.

[7] Finished model.

[8] Save the part with the file name Fork.  
Close the file and exit SOLIDWORKS. #



Assembly Modeling
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 X

Unit: in

 Y

 Z

D0
.26
6

0.2
19

5.0
63

0.1875

3.000

0.375

D0.75

D0
.25

Shaft Assembly
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Section 3.1

[1] In this exercise, we'll create a shaft assembly [2, 3].  
The assembly consists of three parts: the Shaft [4] 
created in Section 2.7, a Handle [5], and a Hinge 
[6].  We use a coordinate system for the assembly 
which is coincident with that of the part Shaft.

3.1-1  Introduction [2] The shaft assembly is a 
sub-assembly of the 
clamping mechanism.

[3] Details of the 
assembly.

[5] Handle.

[6] Hinge. #
[4] Shaft.
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3.1-2  Open Shaft

[1] Launch SOLIDWORKS.  
Click Open and select the 

document Shaft, which was 
saved in Section 2.7. #

3.1-3  Create Handle

[2] On Front plane, draw a 
circle centered at the origin 

like this.

[3] Extrude the sketch 3 
in, using Mid Plane 

option.

[1] Click New and create a 
new part.  Set up IPS unit 

system with 3 decimal places for 
the length unit.

[4] Save the part with the 
file name Handle. #
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3.1-4  Create Hinge

[1] Click New and create a new part.  
Set up IPS unit system with 3 decimal 

places for the length unit.

[2] On Front plane, draw a 
circle centered at the origin 

like this.

[3] Extrude the sketch 0.375 
inches, using Mid Plane 

option.

[5] Extrude the sketch 0.75 
inches, using Mid Plane 

option.

[4] On Front plane, draw a 
circle centered at the origin 

like this.



[6] On Right plane, 
draw a circle centered 
at the origin like this.
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[10] Save the part with the 
file name Hinge. #

[7] In the Features 
Toolbar, click 

Extruded Cut.

[8] Select Through All 
(for Direction 1 only).

[9] The finished 
part.
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3.1-5  Create a New Assembly

[2] Click New.

[1] If you pull down the Window 
menu, you can see that three Part 

documents are opened in the 
computer memory.  We now 

create an assembly consisting of 
these three Parts.

[4] Click OK.

[3] Select 
Assembly.

[5] In the Head-Up 
Toolbar, turn on 
View Origins.

[6] This is the origin of the 
new assembly.  We now 

insert the Shaft so that the 
part's coordinate system 
aligns with the assembly's 

coordinate system.

[7] In the 
Property Box, 

select Shaft.



[8] Click the assembly's 
origin.  The Shaft is inserted 

and its coordinate system 
aligns with the assembly's 

coordinate system. #

3.1-6  Insert the Other Components
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[2] Select Handle.

[3] And click anywhere in 
the Graphics Area to 
temporally park the part.

[1] In the Assembly 
Toolbar, click Insert 

Components.



[4] Repeat steps [1-3] 
(last page) to insert the 

Hinge. #

3.1-7  Assemble Handle
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[1] In the Assembly 
Toolbar, click Mate.

[2] Select the cylindrical 
face of the Handle.

[3] Select the cylindrical 
face of the Shaft's hole.

[4] The selected two 
faces appear here.

[5] A Concentric 
mate is automatically 

selected.

[6] Click OK to accept the 
Concentric mate without 

dismissing the Property Box.



[7] The Handle is assembled into the 
hole of the Shaft.  However, the 

Handle is not well positioned yet (you 
may move it using your mouse); an 

additional Mate is needed.  One way is 
to align the Front plane of the Handle 
with the Front plane of the assembly.

[8] In the Part Tree (which is in 
the Graphics Area; expand the 
tree if necessary), select Front 

plane of the assembly.

[9] Select Front plane 
of the Handle.  Expand 

the tree if necessary.
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[10] A Coincident 
mate is automatically 

selected.

[12] This completes the assembly of 
the Handle.  The handle still can 
rotate about its axis, however, we 

neglect this deficiency. #

[11] Click OK to 
accept the 

Coincident mate 
without dismissing the 

Property Box.



3.1-8  Assemble Hinge

[2] Click this 
cylindrical face 
of the Hinge's 

hole.

[1] While the Mate 
Property Box is still 

active (if not, simply click 
Mate command again, see 
3.1-7[1], page 93), click this 

cylindrical face of the 
Shaft.
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[4] The Hinge is not fixed 
yet.  Use your mouse to slide 

the Hinge along the 
Shaft's axial direction.

[5] Select the 
circular face at the 
end of the hole.

[6] And select this 
circular face of the 

Shaft.

[8] The Hinge is not fixed yet; it 
can rotate about the Shaft's axial 

direction.  We need one more 
Mate.

[3] Click OK to 
accept the 

Concentric mate.

[7] Click OK to accept 
the Coincident mate.



[10] Select the Front plane 
of the Hinge.  Expand the 

tree if necessary.

[9] Select the Front 
plane of the assembly.
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[13] Save the assembly with the 
file name ShaftAssembly.  The 

full name of the document is 
ShaftAssembly.SLDASM.  

Exit SOLIDWORKS. #

[11] Click OK to accept 
the Coincident mate.  Click 

OK again to dismiss the 
Mate command.

[12] The finished 
assembly.  Note that 
we've turned off the 

View Origins from the 
Head-Up Toolbar.



Universal Joint
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Section 3.2

[1] In this exercise, we'll create a universal joint [2].  The assembly consists of four kinds of parts [3-6], of which the 
Yoke [3] was created in Section 2.3.

3.2-1  Introduction

Unit: in.

[3] 2 x Yoke 
(created in 

Section 2.3).

[4] Swivel.  
OD1.00, ID0.50, 

L2.15.

[5] 4 x Bushing.  
OD0.75, ID0.50, 

L0.60.

[6] 4 x Pin. 
D0.50, L1.35. #

[2] The 
universal 

joint.
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3.2-2  Open Yoke

[1] Launch SOLIDWORKS.  
Open the part document Yoke, 
which was saved in Section 2.3. #

3.2-3  Create Swivel

[1] Click New and create a 
new part.  Set up IPS unit 

system with 3 decimal places for 
the length unit.

φ1.0
φ0.5

2.1
5

[2] Create a 3D model like this.  Use 
any coordinate system as your 

convenience.  Save the part with the 
file name Swivel. #
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3.2-5  Create Pin

[1] Click New and create a 
new part.  Set up IPS unit 

system with 3 decimal places for 
the length unit.

φ0.5

1.3
5

[2] Create a 3D model like this.  
Use any coordinate system as 

your convenience.  Save the part 
with the file name Pin. #

3.2-4  Create Bushing

[1] Click New and create a 
new part.  Set up IPS unit 

system with 3 decimal places for 
the length unit.

φ0.75
φ0.5

0.6
0

[2] Create a 3D model like this.  Use 
any coordinate system as your 

convenience.  Save the part with the 
file name Bushing. #
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3.2-6  Create a New Assembly

[4] Click OK.

[3] Select 
Assembly.

[5] In the Head-Up 
Toolbar, turn on 
View Origins.

[6] This is the origin of the 
new assembly.  We now 

insert the Swivel so that 
the part's coordinate system 

aligns with the assembly's 
coordinate system.

[2] Click New.

[1] If you pull down the Window 
menu, you can see that four Part 

documents are opened in the 
computer memory.  We now create 
an assembly which consists of these 

four kinds of Parts.

[7] In the 
Property Box, 
select Swivel.
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[8] Click the origin.  Now the 
Swivel is inserted and fixed 
in the space.  It's okay if your 
origin is not at the center of 

the Swivel.

3.2-7  Insert Bushings and Pins 

[1, 3] In the Assembly 
Toolbar, click Insert 

Components.
[2] Select Bushing 
and click anywhere in 
the Graphics Area 

to park the part.  
Repeat steps [1, 2] 
three more times.

[4] Select Pin and click anywhere in the 
Graphics Area to park the part.  

Repeat steps [3, 4] three more times. #

[9] Select IPS unit 
system. #
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3.2-8  Assemble Bushings and Pins 

[2] Create 8 Concentric 
Mates, so that each Bushing 

and each Pin aligns with its 
respective cylindrical face in the 
Swivel.  Use your mouse to 
drag the parts to appropriate 

positions.

[1] In the Assembly 
Toolbar, click Mate.

[3] While the Mate command is 
still active, click an outer face of 

the Swivel.

[4] and click the 
inner face of the 
corresponding 

Bushing.

[5] Click OK to accept the Coincident 
mate.  Repeat [3, 4] for other 3 Swivel/

Bushing pairs.  Finally, click OK to 
dismiss Mate command.



3.2-9  Assemble Yokes

[1] Click Insert 
Components.
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[2] Select Yoke and click 
anywhere in the Graphics 

Area to park the part.  Repeat 
steps [1, 2] one more times.

[3] Click Mate.

[4] Select the cylindrical 
face of a pin.

[5] And select the cylindrical 
face of a hole of a Yoke.  Click 
OK to accept the Concentric 

mate.

[6] Four 
Bushings are at 

their positions 
now. #



[6] Drag the Yoke to a 
position roughly like this.

[7] While the Mate command is 
still active, click the cylindrical 

face of another pin.

[8] And select the 
cylindrical face of a 

hole of another 
Yoke.  Click OK.  

to accept the 
Concentric mate.

[9] Drag the lower Yoke to 
a position roughly like this.

� Section 3.2  Universal Joint� 104

[12] Click this face 
and the symmetric 

face on the other side.

[10] Click 
Advanced Mates.[11] Select 

Width.

[13] The selected two 
faces appear hear.

[14] Click this face 
and the symmetric 

face on the other side.

[15] The 
selected two 
faces appear 

hear.

[16] Click OK to 
accept the mate.



[17] Now, the middle plane of 
Yoke's two selected faces is 
coincident with the middle 
plane of Bushings' two 

selected faces.

[18] Repeat foregoing 
procedure (steps 

[11-16], last page) for the 
lower Yoke.

[20] Click this 
face.
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[21] And click 
this face.

[23] Now, a 
Pin's outer 

face aligns with 
a Yoke's outer 

face.

[19] Click Standard 
Mates.

[24] Repeat the 
foregoing procedure 
(steps [20-22]) for 3 
other pins.  Finally, 

click OK to dismiss 
Mate command.

[25] Note that the 
Swivel is fixed (3.2-6[8], 
page 101).  The Yokes 
can be move relative to 
the Swivel.  Now, we 

want to release the 
Swivel and fix the upper 

Yoke instead. #

[22] Click OK.



3.2-10  Fix Upper Yoke
[1] An (f) before the Swivel indicates that the Swivel is 
fixed.  Right-click the Swivel and select Float from the 

Context Menu.  The (f) sign turns to (-) sign, indicating 
that it is not fixed any more.  Using your mouse, you can 

move every part of the assembly.  Let's fix the upper Yoke.  
To do that, you could simply right-click Yoke<1> and 

select Fix from the Context Menu.  Another way is to 
create three Coincident Mates [2-4].

[2] Click Mate.
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[3] Click Front plane 
of the assembly.

[4] Click Front plane of the 
upper Yoke (Yoke<1>).  

And click OK.  Repeat [3, 4] 
for Top plane and Right 

plane.  Click OK to dismiss 
Mate command.

[5] Now, the upper Yoke 
is fixed in the space.

[6] Use your 
mouse to move 

the lower Yoke.

[7] Save the assembly 
with the file name 

Joint.  Exit 
SOLIDWORKS. #



[1] In this section, we'll create a clamping mechanism mentioned in Sections 1.1, 2.4, 2.7, and 3.1.  The assembly 
consists of 8 kinds of components [2-9], of which the Arm [2] was created in Section 1.1, the Support [3] was 
created in Section 2.4, and the ShaftAssembly [4] was created in Sections 2.7 and 3.1.  Details of other 
components are shown in [10-15].

Clamp
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Section 3.3

3.3-1  Introduction

[3] Support (see 
details in page 56).

[2] Arm (see 
details in page 3).

[6] PinA (see details 
in [11], next page).

[4] ShaftAssembly 
(see details in pages 75 

and 87).

[8] PinC (see details in [13], 
next page).

[7] PinB (see details in 
[12], next page).

[5] Grip (see details in 
[10], next page).

[9] HingeB (see details 
in [14, 15], next page).



� Section 3.3  Clamp� 108

0.75

0.375

D0.312D0.25

0.75

1.125

D0.312D0.25

1.125

0.375

D0.25 D0.312

[10] Details of Grip. [11] Details of PinA.

[12] Details of PinB. [13] Details of PinC.

0.
75

1.375

0.375

Thickness: 0.25

D0.312

0.
37
5

Unit: in.

[15] Details of HingeB. #[14] HingeB.  The 
internal threads are 

neglected here.

0.75

1.0

D0.75

D0.25

D0.375 Through All
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3.3-2  Create Grip

[1] Launch SOLIDWORKS.  
Click New to create a new part.  

Set up IPS unit system with 3 
decimal places for the length unit.

3.3-3  Create PinA

[1] Click New to create a new 
part.  Set up IPS unit system with 3 
decimal places for the length unit.

[2] Create a 3D model like this.  The 
details are shown in 3.3-1[11] (last page).  

Use any coordinate system as your 
convenience.  Save the part with the file 

name PinA. #

[2] Create a 3D model like this.  The 
details are shown in 3.3-1[10] (last page).  

Use any coordinate system as your 
convenience.  Save the part with the file 

name Grip. #

3.3-4  Create PinB

[1] Click New to create a new 
part.  Set up IPS unit system with 3 
decimal places for the length unit.

[2] Create a 3D model like this.  The 
details are shown in 3.3-1[12] (last page).  

Use any coordinate system as your 
convenience.  Save the part with the file 

name PinB. #
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3.3-5  Create PinC

[1] Click New to create a new 
part.  Set up IPS unit system with 3 
decimal places for the length unit.

[2] Create a 3D model like this.  The 
details are shown in 3.3-1[13] (page 
108).  Use any coordinate system as 

your convenience.  Save the part 
with the file name PinC. #

3.3-6  Create HingeB

[1] Click New to create a new 
part.  Set up IPS unit system with 3 
decimal places for the length unit.

[2] Create a 3D model like this.  
The details are shown in 3.3-1[14, 

15] (page 108).  Use any coordinate 
system as your convenience.  Save 

the part with the file name 
HingeB. #
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3.3-7  Create a New Assembly and Insert a Support

[4] In the 
Head-Up 

Toolbar, turn 
on View 
Origins.

[1] Click New.

[3] Click OK.

[2] Select 
Assembly.

[5] The assembly's origin.

[7] Click the origin.  The 
Support is inserted and fixed 

in the space.

[6] Click Browse and open 
the part Support, which was 

saved in Section 2.4.

[8] Select IPS 
unit system. #
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3.3-8  Mirror the Support

[1] In Assembly Toolbar, pull-down 
Linear Component Pattern and 

select Mirror Components.
[3] The Front 

plane of the 
assembly.

[2] For Mirror 
plane, select the 

Front plane of the 
assembly (see [3])

[4] For Components 
to Mirror, select 
Support from the 

Part Tree (see [5]).

[6] Click 
Next.

[7] Click Create 
opposite hand 

version.

[5] The 
Support.

[8] Click 
Next.

[9] It says that the geometry 
of the mirrored Support is 

different from the original one.  
By default, a new file with the 
name MirrorSupport (in 

the same folder as Support) 
will be created.

[10] Click OK.  
Click Yes for 
any warning 
messages. 

[11] Save the assembly 
with the name Clamp. #
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3.3-9  Unfix the Supports

[1] In the Features Tree, 
an (f) sign before Support 

indicates that it is fixed.

[2] Right-click Support and 
select Float from the 

Context Menu.  The (f) sign 
turns to (-), indicating that 
Support is not fixed now.

[3] Using your mouse, drag the original 
Support so that the original and the 
mirrored Supports separate from 
each other like this.  Note that we've 

turned off View Origins,.#

3.3-10  Assemble Two PinBs

[1] In the Assembly 
Toolbar, click Insert 

Components.

[2] Select PinB and park 
anywhere in the Graphics 

Area.

[3] Hold the Control key and click-
and-drag PinB.  Another PinB is 

duplicated.

[4] Click Mate.
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[5] Apply a Concentric 
Mate and two Coincident 

Mates to assemble this 
PinB (see [6]).

[6] After the assembling, 
the spacing between two 

Supports is 0.75 in.

[7] Apply a Concentric Mate 
and a Coincident Mate to 
assemble this PinB (see [8]).

[8] Both PinBs 
are assembled.  Click 

OK to dismiss 
Mate command.  

Save the file.

[9] Right-click Support<1> and 
select Fix from the Context 

Menu.  The (-) sign turns to (f), 
indicating that the Support is fixed 
in the space.  If an error messages 

window appears, see [10].

[10] An error messages window may appear when executing 
step [9], saying that the assembly is over defined.  The 

assembly is actually not over defined.  To fix this problem, 
close the messages window, right-click Support<1> and 

select Float, and execute step [9] again. #
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3.3-11  Assemble PinC

[1] In the Assembly Toolbar, 
click Insert Components, 

select PinC and park anywhere 
in the Graphics Area.

[2] Apply a 
Concentric Mate 
and a Width Mate 
(Advanced Mates) 

to assemble PinC.  
Dismiss Mate 

command.  Save the 
file. #

3.3-12  Assemble Arms

[1] In the Assembly 
Toolbar, click Insert 
Components, browse 
and open Arm, which 

was saved in Section 1.1, 
and park anywhere in the 

Graphics Area.

[2] Apply a Concentric 
Mate and a Coincident 

Mate to assemble the Arm.  
Dismiss Mate command.

[3] Hold the Control 
key and click-and-drag 
Arm.  Another Arm 

is duplicated.

[4] Repeat step [2] for the 
new Arm.  Note that the 

spacing between two Arms is 
0.375 inches.

[5] Note that each 
Arm can rotate 
about the PinC 
independently.

[6] Create a 
Concentric Mate 

so that the two 
Arms align with 

each other.  Dismiss 
Mate command.  

Save the file. #
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3.3-13  Assemble PinA
[2] Apply a 

Concentric Mate and a 
Width Mate 

(Advanced Mates) to 
assemble PinA.  Dismiss 

Mate command.  Save the 
File.#

[1] In the Assembly Toolbar, 
click Insert Components, 

select PinA and park anywhere 
in the Graphics Area.

3.3-14  Assemble Grip

[1] In the Assembly Toolbar, 
click Insert Components, 

select Grip and park anywhere 
in the Graphics Area.

[2] Apply a Concentric Mate and a 
Width Mate (Advanced Mates) 

to assemble Grip.  Note that the 
Grip can rotate about PinA.

[4] Select the top face (or 
bottom face) of the Grip 
and the assembly's Top 
plane (or any horizontal 

face, such as [5]).

[3] Click to switch to 
Standard Mates.

[6] Click Parallel.  
Click OK to 
accept the 

Parallel Mate.  
Click OK again to 
dismiss the Mate 
command.  Save 

the file.

[5] You may select 
this horizontal face.
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3.3-15  Assemble HingeB

[7] Drag the Grip to 
make sure that it keeps in 
a horizontal position. #

[1] In the Assembly Toolbar, 
click Insert Components, 

select HingeB and park 
anywhere in the Graphics 

Area.

[2] Apply a Concentric 
Mate and a Width Mate 

(Advanced Mates) to 
assemble HingeB.  Dismiss 

Mate command.  Save the file.
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3.3-16  Assemble ShaftAssembly

[1] In the Assembly 
Toolbar, click Insert 

Components, browse and 
open ShaftAssembly, which 
was saved in Section 3.1, and 

park anywhere in the 
Graphics Area.

[2] Apply a 
Concentric Mate 

between this 
cylindrical surface and 

a hole in Arm.

[3] And apply a Concentric 
Mate between the hole of  

HingeB and a cylindrical surface 
of Shaft.  Dismiss Mate 
command.  Save the file.

3.3-17  Test the Clamping Mechanism

[1] Drag any component to see 
how the mechanism works.  
Note that the Grip keeps 

horizontal.

[2] Exit SOLIDWORKS. #
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Right, 71
Round-cornered box, 4

Front, 6
Full Round Fillet, 52, 53
Geneva, 49
Geneva Gear Index, 43
Geometry pattern, 85
Global coordinate system, 3
Graphics Area, 6, 8
Grip, 107, 108, 109, 116
Handle, 87, 88
Head-Up Toolbar, 9, 25
Hide/Show Items>View Planes, 73
Hide/Show Items>View Sketch Relations, 25, 51
Hinge, 87, 89
HingeB, 107, 108, 110, 117
Hole, 42, 48
Hole Type, 48
Hole Wizard, 49, 53
Horizontal, 10, 39, 45
Horizontal dimension, 9
Image Quality, 7
Inference Line, 9
Infinite length, 18, 26
Insert Components, 92, 101
Insert>Boss/Base>Extrude, 15
Insert>Boss/Base>Revolve, 65
Insert>Boss/Base>Sweep, 68
Insert>Cut>Extrude, 42
Insert>Features>Fillet/Round, 52
Insert>Features>Hole>Wizard, 48
Insert>Pattern/Mirror>Circular Pattern, 47
Insert>Reference Geometry>Plane, 54
IPS, 5, 17
Isometric, 41
Joint, 106
LCD, 80
Line, 12, 15
Linear Component Pattern, 112
Linear Pattern, 84
Linear Sketch Pattern, 21
Liquid crystal display, 80
Loft, 80
Lofted Boss/Base, 84
Major diameter, 75
Mate, 93, 102
Mid Plane, 52
Mirror, 64, 72, 112
Mirror about, 64
Mirror Components, 112
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Save, 16
Second Reference, 71
Shaft, 79, 87, 88
Shaft Assembly, 87
ShaftAssembly, 96, 107, 118
ShaftAssembly.SLDASM, 96
Sharp-cornered box, 4
Sketch, 6
Sketch Fillet, 14, 15, 39
Sketch Toolbar, 9, 15
Sketching, 2
Smart Dimension, 6, 9
SolidWorks, 4
SolidWorks Terms, 4
Standard Mates, 105, 116
Standard Views Toolbar, 41, 67, 69
Stop, 27
Sub-assembly, 87
Support, 56, 61, 107, 111, 113
Sweep, 66, 68
Sweeping Path, 77
Sweeping Profile, 77
Swept Cut, 77
Swivel, 97, 98
Symmetric, 45
Tangent, 25, 45
Tangent Arc, 24
Tangent line, 13
Textboxes, 4
Thread form, 75
Through All, 42, 78
Toolbar, 8, 16
Tools>Options, 5
Tools>Sketch Tools>Circular Pattern, 21
Tools>Sketch Tools>Mirror, 64
Top, 54
Transition Pipe, 66
Trim Entities, 13, 15
Trim to closest, 13
Two Planes, 71
Undo, 7, 13
Unfixed entity, 46, 51
Unified National Coarse, 75
Units, 5
Universal Joint, 50, 97
Up To Surface, 55
User interface, 4
Vertical, 11, 39

View Orientation>Isometric, 41
View Orientation>Normal To, 40
View Origins, 91, 96, 100
View Planes, 55, 60
Well-defined, 6
Wheel, 62, 65
Width Mate, 104, 115, 116
Window, 16, 91
Yoke, 50, 55, 97, 98, 103, 106
Zoom in/out, 7
Zoom to Fit, 9
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